Routing in the Data Center

By | July 3, 2014

Types of Routes:

  • Direct Route – Directly attached to the router interface.
  • Static Route – Used to tell your router statically where to direct traffic:

ip route 10.10.30.0/24 10.10.10.100

Meaning 10.10.30.0/24 can be reached via 10.10.10.100.  This can be confirmed by viewing the routing table with:

show ip route

  • Dynamic Route – Determined using a protocol such as OSPF, RIP, or EIGRP.
  • Default – If a route is not specified in the routing table this will send your traffic out of this route:

ip route 0.0.0.0/0 192.168.1.100

Then confirm the default route using:

show ip route

This is also known as the Gateway of Last Resort since there are no other matches in the routing table.

Inter-VLAN Routing:

This was done using sub interfaces (AKA Router on a stick).  Since routers support 802.1Q trunks we can use one port on the router and trunk everything over from the switch.  However this will introduce a single point of failure and bandwidth concerns.  Instead Layer 3 has been built into newer switches to allow the switch to route.   In a Layer 3 switch, you will use SVI’s (Switched Virtual Interfaces) to hold the gateway addresses:

int vlan 10
ip address 10.10.10.1/24
int vlan 20
ip address 10.10.20.1/24

You can also create routed ports by running:

int e2/10
no switchport

Distance Vector Protocols:

Includes protocols such as RIP and RIPv2.  It records a direction and distance (AKA the metric) to determine the route paths.  This metric is based off hop counts between routers.  The problem with this approach is that you “Route by Rumor” because you depend on other devices to pass along routing information per hop.  This also makes the protocol far more chatty and can lead to corrupt information and routing loops.  The maximum hop count for RIP is 16 and is designed with small networks in mind.  You can configure RIP with:

feature rip
router rip rip-name

int e2/1
ip router rip rip-name

Link State Protocols:

Includes protocols such as OSPF and IS-IS.  To configure OSPF you would run:

feature ospf
router ospf proccess-id

int e2/3
no switchport
ip address 10.10.40.1/24
ip router ospf process-id area area-id

EIGRP

Combines some properties of Distance Vector and Link State which can be considered a hybrid protocol and has recently been opened up to the rest of the world to become an open standard!   It can use D.U.A.L to create a failover scenario and is one of the only protocols that can do so.  To configure:

feature eigrp
router eigrp AS-Number

int e2/1
ip router eigrp AS-Number