WAN Connections: Frame Relay

By | July 7, 2013

Frame Relay is typically used in packet switched networks.  Packet switched networks let service providers share unused bandwidth across lines.  This allows the service provider to sell cheaper connections since you may not use all of the bandwidth.  They can also over provision the cloud they are sharing.

The terms to know are as follows:

CIR (Commited Information Rate) – The minimum about of B/W that’s committed.  You can burst above this if the bandwidth is available as long as you aren’t continually exceeding your CIR.

LAR (Local Access Rate) – This is physically how fast the circuit can go.  The cable can not handle over the LAR.  Your speed will still be limited to the CIR.

LMI (Local Management Interface) – This is the language spoke between your router and service provider.  It is a signaling protocol that allows the service provider to send you various statistics.

DLCI (Data Link Connection Identifier) – This is the replacement of mac addresses on your line.  They work differently than mac addresses and will be discussed below.

PVC (Permanent Virtual Circuit) – Your physical interface will have PVC’s that dictate where your service provider will allow you access to.  Your PVC’s speed is limited by your CIR.  You can have multiple PVC’s going to multiple locations using different CIR’s.  You normally pay for the total B/W allocation of CIR’s.  The more PVC’s you have, the more you pay.

How DLCI’s Work:

This is the addressing Frame Relay uses.  DLCI’s are locally significant meaning that each that when the local area sends it sends it to its local DLCI identifier.  When service provider will handle it and when your remote location sees it coming in, it will have the number of its own local DLCI.  So if TX had a DLCI of 200 and AZ had a DLCI of 100 TX would send to 200 and AZ would see it arrive from DLCI 100.  Look at the DLCI numbers as airline gates.  If you leave from gate B23 you may arrive from gate A15 at your actual destination.  Certain locations may actually have the same DLCI numbers unlike TCP/IP and Ethernet technology.  Since they are locally significant the DLCI in CA that is 200 could share the same DLCI number 200 in AZ.  You can not have the same DLCI numbers in the same local interfaces however.  They only need to be different locally.  What the Service Provider actually does in the cloud is hidden and magically, they don’t even truly care about the DLCI and the packet gets heavily manipulated.

Types of Frame Relay PVC Designs

Hub and Spoke – Yours remote locations share PVC’s and route through centralized or core routers on your network to reach eachother.  I.E MO, TX, and CA must all route through MD to reach eachother.  This is cheap but can cause delays.

Full Mesh – Every office has it’s own PVC to every other office.  This is expensive but peforms very well.

Partial Mesh – This is the combination of the two above.  Balances cost and performance to create a good… well… mesh 😉 Your non critical locations usually have one PVC or share with a core site while your critical ones have multiple stand alone PVC’s.

Interface Design

Multipoint Design:

  • All routers serial interfaces to the WAN are on the same subnet
  • Multiple DLCI numbers are mapped to the intefaces
  • Causes problems with split horizon networks.  Split horizon is a loop prevention mechanism that happens with distance vector networks.  Since routers can not advertise on the same line they received a specific route with split horizon, it prevents a central location from sending out other routes to other peers on the interface used for the WAN.  Therefore split horizon must be turned off.

Point to Point Design:

In this design your main router will have multiple sub interfaces connecting to multiple other sites that do not use sub interfaces.  It mimics the behavior of having multiple leased lines to each location when in reality it doesn’t.

Each sub interface will have its own subnet connecting to the corresponding subnet on it’s remote router it is connecting to.  it is the same concept as router on a stick.

Configuration:

Here let’s go through the steps of configuring both Point to point over Frame Relay packet switched networks and Multi point configurations.  You will probably realize, point to point with the sub interfaces is superior.

Multipoint Configuration:

Lets say R1, R2, and R3 are our 3 routers and R1 is the central point using S0/1/0 on 192.168.1.1/24.  This connections to both R2 and R3 and S0/0 and S0 respectively using 192.168.1.2/24 on R2 and 192.168.1.3/24 on R3.

R1:

conf t

int s0/1/0
ip address 192.168.1.1 255.255.255.0 – give the interface an IP
encapsulation frame-relay – specify we want to use frame-relay
frame-relay lmi-type  – specifying the type of signaling you will be using to the provider.  This is only required for older routers.
no shutdown – power the interface u

show frame-relay lmi – shows the signaling between you and the service provider.  The number of messages sent should be equal to the number received.  If timeouts are increasing you may have a mismatch.

int s0/1/0
frame-relay map ip 192.168.1.2 102 ietf broadcast – maps the DLCI remote IP address we want to get to from our router 1 to R2 using the DLCI assigned (102).  If you have Cisco routers on both ends you don’t need the IETF syntax in the command since ietf is the industry standard for non Cisco routers.  The broadcast command allows you to send you broadcasts/multicasts across the link for your internal routing protocols such as OSPF and EIGRP.
frame-relay map ip 192.168.1.3 103 broadcast – creates the map to our R3 using the same syntax.  I left off ietf this time since it is mapping to a Cisco router.

show frame-relay map – Shwos which DLCI is assigned to which IP so you can see how they are mapping and if it is active.  This will currently be inactive since the other side is not configured.  If the status is deleted it means the DLCI doesn’t exist and the remote endpoint probably doesn’t either.

Now lets configure Router 2 to complete the connection to router 1:

R2:

conf t
int s0/0

ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
no shutdown
frame-relay map ip 192.168.1.1 201 ietf broadcast – Specified our local DLCI to router2 and the remote IP address of router 1 we are trying to reach.

show frame-relay lmi – should show that the messages are being sent and received properly.
show frame-relay map – should show the new map as active
show ip interface brief – should show the serial interface as up with protocol ip.

Finally now that all that is working properly, time to configure Router 3 to connect to router 1:

R3:

conf t
int s0
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
no shutdown
frame-relay map ip 192.168.1.1 301 broadcast – Map our DLCI 301 to 192.168.1.1 (router 1).

Since this is our hub and spoke multi-point configuration router 3 will now show the DLCI’s allowed on the frame relay network.  Some may have been auto discovered and will show as dynamically discovered.  In our case, there shouldn’t be any dynamically discovered DLCI’s since we manually configured them all.

Now since R2 and R3 both must connect to R1 in order to reach each other, we need to create another static map.  This is only necessary in this hub and spoke multi point configuration:

R3:

conf t
int s0
frame-relay map ip 192.168.1.2 301 broadcast – this tells R3 that it can also reach R2 through the same DLCI it is hitting router 1 with which is the case since they have direct connections to R1.  Once we create the map on R2 they will be able to connect

R2:

conf t
s0/0
frame-relay map ip 192.168.1.3 201 broadcast – Now R2 is configured to reach R3 through the same DLCI it reaches R1 on.

In order for routes to be advertised on this type of setup, be sure to disable split horizon!

Point to Point Configuration:

In this instance the routers will be configured like so:

R1 has two sub interfaces, s0/1/0.102 with the IP of 192.168.1.1/24 and s0/1/0.103 with the IP 192.168.2.1/24.  Each sub interface has the corresponding DLCI 102 and 103 (matches the sub interface numbers).
R2 has one sub interface named S0/0.201 with the IP 192.168.1.2/24 and the DLCI 201.
R3 has one sub interface named S0/0.301 with the IP 192.168.2.2/24 and the DLCI 301.

It is smart to name your sub interfaces to match the DLCI so you can easily keep track and add new ones if need be.

Lets say we removed all of our configs for multi point and all routers are running EIGRP.  Starting with Router1:

R1:

conf t
int s0/1/0
encapsulation frame-relay – turns on frame-relay encapsulation for the whole inteface including subs we are about to create.

int s0/1/0.102 point-to-point – creates the sub interface as a point to point sub interface
ip address 192.168.1.1 255.255.255.0 – assign our IP
frame-relay interface-dlci 102 – says to use DLCI 102 anytime this sub interface is used.  No map needed!

int s0/1/0.103 point-to-point – creates sub interface for point to point
ip address 192.168.2.1 255.255.255.0 – assigns our IP
frame-relay interface-dlci 103 – specifies our DLCI 103

int s0/1/0
no shutdown – brings up our main interface which brings up the sub interfaces

Time to configure router2:

R2:

conf t
int s0/1
encapsulation frame-relay

int s0/1.201 point-to-point
ip address 192.168.1.2 255.255.255.0
frame-relay interface-dlci 201

int s0/1
no shut

R3:

conf t
int s0
encapsulation frame-relay

int s0.301 point-to-point
ip address 192.168.2.2 255.255.255.0
frame-relay interface-dlci 301

int s0
no shut

show ip interface brief – now check to ensure the interface comes up.

show frame-relay map – you will see the sub interface comes up and goes active without specifying a map.

Now all of your pings should be working across your sub interfaces.  Even though R2 and R3 map through R1, since EIGRP can advertise the routes over the proper links, it will take care of itself and they will be able to talk to each other with no additional configuration.  The only downside is that each individual point to point connection needs its own subnet but it is actually worth it.

show frame-relay map – Gives you a quick overview of your DLCI’s that have been mapped and what end points they map to.

show frame-relay pvc – shows every DLCI you have, the interface it is on, and the amount of packets sent.  It’s an expanded version of show frame-relay map

show frame-relay lmi – shows the communication between you and the service provider.  As long as sent/receive are counting up you know you are good to go.